gstreamer_live_overlay_object_detector.py hangs

I just installed xnor-eval-sdk-v0.3 on my ubuntu desktop (ubuntu 16.04 LTS) and when I run the live overlay sample it just hangs with a blank window,

I have tried another sample gstreamer_live_background_blur.py and that runs without any issues.

Command:

python3 gstreamer_live_overlay_object_detector.py --webcam_device /dev/video0

Regards,

Simon

2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • interesting, just hangs? Does it do same thing without the --webcam?

    Reply Like
  • Todd,

    Thanks for your response.. I have tried it again today and it has started working!

    I have worked out the issue is related to my other bug report, regarding the models having the same wheel name and lib xnornet.so name.

    Steps to reproduce:

    1. Install segmenter model wheel, pip install etc..
    2. Uninstall the segmenter model wheel
    3. install the segmenter model
    4. run python3 gstreamer_live_overlay_object_detector.py --webcam_device /dev/video0  

    I suspected in might be to do with the library xnornet.so library so I tried sudo ldconfig but still the same. But after a shutdown (not reboot) the script runs without any problems.

    Reply Like
Like Follow
  • Status Fixed
  • 7 mths agoLast active
  • 2Replies
  • 30Views
  • 2 Following